tomorrow's connected future is here today

Surface Pro 3 WiFi

Some Theories on WiFi Issues with Surface Pro 3

 

I’ve been reading about issues with WiFi connectivity in the Microsoft Community Forums (and trying to help folks with these problems), primarily in two long threads:

 

http://answers.microsoft.com/en-us/surface/forum/surfpro3-surfnetwork/surface-pro-3-limited-wifi-problem/bd17691d-f00d-491c-a65e-fcd77a304b3a

http://answers.microsoft.com/en-us/surface/forum/surfpro3-surfnetwork/surface-pro-3-wifi-and-network-connections-driver/69c3cd0f-daac-44be-bec6-643d2e53f98a

 

I have some theories, but am having trouble extracting answers to my questions in these threads because I’m asking afflicted users to make changes to their router configurations WHICH THEY SHOULD NOT HAVE TO DO UNDER NORMAL CIRCUMSTANCES. I’ve developed a couple of theories about some of the connectivity issues.

 

1. SLOW WIFI: Some routers (Apple has been doing this for years) ship with both the 2.4 and 5 GHz channels set to the same SSID (name). Other vendors have started doing this, some by default, others let you specify this optionally. It’s marketed as an “Smart Connect” type config where the “best” channel is selected by the client/router automatically. I asked a couple of users in the forum about their config and learned that they were using the same SSID. I asked them to make a change and specify unique SSIDs and attach to 5GHz. They’ve reported their problem has disappeared.

Over the weekend, I experimented with my newest Netgear Router, the newly released R8000. This router has TWO 5GHz radios that support the newest 802.11AC speeds. Netgear optionally offers the “Smart” connect where you can enable the same SSID name.

smartconnect

You have no control which radio you connect to when this is enabled.

If you enable this kind if smart connect on routers covering both the 2.4 and 5GHz bands on certain routers, apparently you will always connect to the 2.4GHz SSID if you are using a Surface Pro 3.

For folks with 2.4GHz 802.11n routers with no 5GHz, your speeds will be slower than if you had a dual band router. There’s just no getting around this.

 

2. LIMITED CONNECTIVITY WHEN COMING OUT OF INSTANT GO ‘SLEEP’: Most routers ship with channels set to auto select so that the user doesn’t have to figure out what channel has the least interference/usage. I’ve always changed this to specific channels here and have had no issues. My theory here is that while the SP3 is in InstantGo sleep mode, the channel has changed and the Marvell adapter can’t find it. Similarly, if the initial connection is made, while using the SP3, if the channel changes, the same “can’t find new channel” situation occurs. I’ve been asking people to make changes in their settings to test this. Again, I know this should not be necessary. But it would seem to be a great diagnostic.

Blue Screen Crash on Surface Pro 3 with wificlass.sys

 

Microsoft Communities users are reporting a blue screen crash in wificlass.sys in a growing thread: http://answers.microsoft.com/en-us/surface/forum/surfpro3-surfnetwork/surface-pro-3-blue-screen-due-to-wifi/af642571-cd20-41ea-80b3-f2052511b65c

wificlass

As yet, there is no official participation from office Surface support.

I’m wondering how many people are afflicted with this issue. If you are experiencing this, please post in the thread above and also tweet @barbbowman.

Read this blog with my Windows 8 App

Get the App

Categories
Archives